Sign In Start Free Trial
Account

Add to playlist

Create a Playlist

Modal Close icon
You need to login to use this feature.
  • Book Overview & Buying Security Monitoring with Wazuh
  • Table Of Contents Toc
Security Monitoring with Wazuh

Security Monitoring with Wazuh

By : Rajneesh Gupta
3.9 (7)
close
close
Security Monitoring with Wazuh

Security Monitoring with Wazuh

3.9 (7)
By: Rajneesh Gupta

Overview of this book

Strengthen your cybersecurity posture with Wazuh’s powerful security monitoring and compliance capabilities. Security Monitoring with Wazuh is a comprehensive, hands-on guide that helps you deploy, configure, and optimize Wazuh to detect threats, automate incident response, and enforce compliance. With real-world use cases, step-by-step configurations, and tool integrations, this book equips you to build an enterprise-grade defense system. You'll begin by setting up an Intrusion Detection System (IDS) using Wazuh and integrating Suricata to monitor network and host-based threats. Moving forward, you'll explore malware detection, vulnerability assessment, and security automation with SOAR. The book also covers threat intelligence, incident response, and proactive threat hunting, helping you detect and mitigate cybersecurity risks effectively. Beyond detection, you'll enforce compliance with industry standards such as MITRE ATT&CK, PCI DSS, and GDPR, ensuring regulatory adherence and security best practices. By integrating Wazuh with TheHive, Cortex, MISP, and other security tools, you'll streamline threat analysis and response. By the end of this book, you'll master Wazuh's full potential, enabling you to deploy, manage, and enhance security monitoring across your infrastructure—from on-premises to cloud environments.
Table of Contents (15 chapters)
close
close
1
Part 1:Threat Detection
4
Part 2: Threat Intelligence, Automation, Incident Response, and Threat Hunting
9
Part 3: Compliance Management
12
Chapter 9: Glossary

Download the example code files

You can download the code mentioned in the book from the GitHub repository here: https://github.com/PacktPublishing/Security-Monitoring-using-Wazuh

We also have other code bundles from our rich catalog of books and videos available at https://github.com/PacktPublishing/. Check them out!

Disclaimer on images

This book contains many horizontally long screenshots. These screenshots provide readers with an overview of Wazuh's execution plans for various operations. As a result, the text in these images may appear small at 100% zoom. Additionally, you will be able to examine these plans more thoroughly in the output of Wazuh as you work through the examples.

Conventions used

There are a number of text conventions used throughout this book.

Code in text: Indicates code words in text, database table names, folder names, filenames, file extensions, pathnames, dummy URLs, user input, and Twitter handles. Here is an example: “Copy the curl command to download the Wazuh module and start the Wazuh agent service as mentioned in the following diagram.

A block of code is set as follows:

<rule id="200101" level="1"> 
<if_sid>60009</if_sid> 
<field name="win.system.providerName">^PowerShell$</field> 
<mitre>

When we wish to draw your attention to a particular part of a code block, the relevant lines or items are set in bold:

policy: 
   id: "rdp_audit" 
   file: "sca_rdp_audit.yml" 
   name: "System audit for Windows based      system" 
   description: "Guidance for establishing a secure configuration for Unix based systems." 

Any command-line input or output is written as follows:

$ sudo systemctl restart wazuh-agent

Bold: Indicates a new term, an important word, or words that you see on screen. For instance, words in menus or dialog boxes appear in bold. Here is an example: “Suricata is an open-source network intrusion detection and prevention system (IDS/IPS).

Tips or important notes

Appear like this.

CONTINUE READING
83
Tech Concepts
36
Programming languages
73
Tech Tools
Icon Unlimited access to the largest independent learning library in tech of over 8,000 expert-authored tech books and videos.
Icon Innovative learning tools, including AI book assistants, code context explainers, and text-to-speech.
Icon 50+ new titles added per month and exclusive early access to books as they are being written.
Security Monitoring with Wazuh
notes
bookmark Notes and Bookmarks search Search in title playlist Add to playlist download Download options font-size Font size

Change the font size

margin-width Margin width

Change margin width

day-mode Day/Sepia/Night Modes

Change background colour

Close icon Search
Country selected

Close icon Your notes and bookmarks

Confirmation

Modal Close icon
claim successful

Buy this book with your credits?

Modal Close icon
Are you sure you want to buy this book with one of your credits?
Close
YES, BUY

Submit Your Feedback

Modal Close icon
Modal Close icon
Modal Close icon